Bugs

Working with Firefox 18 would be nice...

Scorch is terrific--and Scorch is the standard platform for online music sales. But Scorch has serious issues--enough so that Firefox 18 users are reporting on the Sibelius forum that Scorch is being blocked as a security problem. My understanding is that Scorch development was halted during one of the Avid "re-organizations" at Finsbury Park--and that those developers are aware of a number of significant issues that ...more »

Submitted by (@johnmurdoch)

Voting

21 votes
22 up votes
1 down votes

Bugs

Please lose Java dependency

While I recognize the value of having a common API for the Avid license manager across Windows and Mac, there are multiple problems with how Avid chooses to use Java: 1. the package is installed without the user's express knowledge separate from any preexisting Java package. This creates possible versioning conflicts on the system. 2. the version installed by the Avid installer is (currently) a full version out of date, ...more »

Submitted by

Voting

6 votes
6 up votes
0 down votes